Clock not keeping time - Smart Car Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 11-09-2018, 06:44 AM Thread Starter
 
Join Date: Sep 2018
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Clock not keeping time

2018 Electric smart4two.

The clock for the multi-function dashboard display is not keeping up with actual time. I reset it and it keeps correct time while the car is running. But after the car is shut down for a while (while at work, or overnight), when I return, the time is significantly behind the current actual time. The clock on the radio works just fine.

This happens almost every time I leave the car, whether it is plugged in to a charger or not. However, on rare occasions when I return to the car, the time on the clock will still be correct. Only maybe 4 or 5 times in the 2 months that I have had the car.

Anybody else have a similar experience? If so, any suggestions for solution?

This is a significant disappointment with winter coming as the schedule for the climate control pre-heating runs off this clock.
Frewbud16 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 11-09-2018, 07:29 AM
Bohemian Moderator 451gas
SCOA Club
 
jwight's Avatar
 
Join Date: Oct 2007
Location: Dayton, OH USA
Posts: 27,800
Thanks: 7,333
Thanked 5,765 Times in 3,487 Posts
Mentioned: 9 Post(s)
Tagged: 1 Thread(s)
Quoted: 78 Post(s)
Garage
Welcome to SCoA!
jwight is offline  
post #3 of 6 (permalink) Old 11-10-2018, 02:57 PM
 
Join Date: Mar 2015
Location: Pittsburgh, USA
Posts: 857
Thanks: 10
Thanked 78 Times in 72 Posts
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 330 Post(s)
Very odd. I'd expect any kind of electronic clock to work correctly or not at all... Time to take it to a dealer for some warranty work, unfortunately.
Yinzer is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 11-30-2018, 12:22 PM Thread Starter
 
Join Date: Sep 2018
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I did end up taking in to the dealership. At first they said it needed a software update, but that didn't work and they replaced the instrument cluster. Thankfully, covered by warranty.

Now it works fine.
Frewbud16 is offline  
post #5 of 6 (permalink) Old 04-08-2019, 10:23 PM
 
E SMART's Avatar
 
Join Date: Aug 2007
Location: Chicago
Posts: 624
Thanks: 38
Thanked 85 Times in 51 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Good to know

we have the same issue; clock seems to have a mind of its own -- will be sure to have them check it out at its annual check up in July and see if a new head unit is in order -- more just annoying that a real issue as I really only use it to determine when it will be fully charged so I can disconnect the charging cable. The rest of the car has been great and with a break in our spring weather is showing 90+ miles of range again
E SMART is offline  
post #6 of 6 (permalink) Old 04-09-2019, 04:46 AM
 
Join Date: Dec 2010
Location: Eastern Panhandle, WV
Posts: 1,289
Thanks: 47
Thanked 186 Times in 147 Posts
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 231 Post(s)
The clock on the tach/cluster in my 2016 ICE loses time. Not dramatically, but will be off a minute or few over the course of a few weeks after setting. Not so with the radio clock.
OliverB is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Smart Car Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Drove my Ed Hardy & KEEPING IT ! Toppy Wisconsin Chapter 14 11-28-2009 12:08 PM
Keeping Her Clean? Has anyone tried... (Re: 5 Star Shine) pwbapro smart General Discussion 16 06-07-2009 04:47 PM
Reservation time to Configuration time to Delivery time t-bone smart News & Rumors 288 03-12-2009 09:54 AM
Orphan Adopters keeping your Reservation? Suze smart General Discussion 19 05-14-2008 01:32 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.