HV battery parts - Smart Car Forums
User Tag List

 1Likes
  • 1 Post By sokoloff
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 09-10-2019, 09:18 PM Thread Starter
 
Join Date: Jul 2019
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hi 👋

Wanted to see if anyone can help me locate a battery current sensor for my 2014 Smart ED.


Any help is greatly appreciated
Attached Images
 
SFmike is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 09-11-2019, 09:01 AM
 
Join Date: Mar 2015
Location: Pittsburgh, USA
Posts: 1,015
Thanks: 13
Thanked 125 Times in 103 Posts
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 383 Post(s)
Unfortunately, you image is not showing due to you being a new member.

Is this the same current sensor talked about in the link below - with some vague possible connection with bricked battery packs which nobody makes clear?

https://github.com/MyLab-odyssey/ED_BMSdiag/issues/19
Yinzer is offline  
post #3 of 8 (permalink) Old 09-11-2019, 10:24 AM Thread Starter
 
Join Date: Jul 2019
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hi.
Yes that is the sensor I’m looking for. I called Smart/Benz and I even called Bosch, they do not sell it on its own.

I tried to look for options, like a aftermarket sensor, a sensor from another car, besides the stated Fiat 500e sensor that someone else use. I found nothing, I’ve been tried eBay. If anyone has a lead on a Used HV pack with a good sensor. I greatly appreciate it. Or if someone knows another sensor from another car (besides Fiat 500e) that will work.

I’m even willing to buy from out of country. Haha.

Thank you all



Quote:
Originally Posted by Yinzer View Post
Unfortunately, you image is not showing due to you being a new member.

Is this the same current sensor talked about in the link below - with some vague possible connection with bricked battery packs which nobody makes clear?

https://github.com/MyLab-odyssey/ED_BMSdiag/issues/19
SFmike is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 09-11-2019, 01:38 PM
Moderator
 
sokoloff's Avatar
 
Join Date: Aug 2013
Location: Ocean Isle Beach, NC
Posts: 1,191
Thanks: 80
Thanked 160 Times in 124 Posts
Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 347 Post(s)
Garage
Can you tell us more about what's going on with your car? We have had multiple discussions here about HV battery issues a few owners have had and we are trying to figure out the causes and connections and of course the fixes.

Thanks.

Len
2014 EV Coupe 19,000 miles
2014 EV Cabriolet 13,500 miles
Yinzer likes this.
sokoloff is offline  
post #5 of 8 (permalink) Old 09-11-2019, 05:54 PM
 
Join Date: Mar 2015
Location: Pittsburgh, USA
Posts: 1,015
Thanks: 13
Thanked 125 Times in 103 Posts
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 383 Post(s)
Yes, what happens when the sensor fails? Is it associated with the battery pack getting discharged flat?
Yinzer is offline  
post #6 of 8 (permalink) Old 09-12-2019, 04:58 AM Thread Starter
 
Join Date: Jul 2019
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hi

Sorry for the late reply

I have a Fault codes for my BMS and sent my BMS our for repairs (was not cheap). Once that was back it was told that it had common problems and guaranteed that all is fix within the BMS. After installing the BMS back into the HV battery and started to see signs of life again as I did a quick initial start up and shut down so I can clean up and get moving. Little did I know there was a few more fault codes. These fault codes are apparently linked to the current sensor, I had a few mechanics checked the codes, clear it and it still there, looked around online and found info on the link u posted as it was the same codes as that, then sent the same codes to person that repaired my BMS and he also confirm it’s the current sensor is bad.

I called friends at Benz/Smart and no luck as they don’t sell that sensor by itself, called Bosch and they don’t sell it to anyone as it’s licensed to Smart/Benz only. So here I am looking for a good used one in hopes that it will fix my problem.

Removing and disassembling the HV battery is not fun. Did it 3 times already. If anyone attempts this. Be VERY careful.


Quote:
Originally Posted by sokoloff View Post
Can you tell us more about what's going on with your car? We have had multiple discussions here about HV battery issues a few owners have had and we are trying to figure out the causes and connections and of course the fixes.

Thanks.

Len
2014 EV Coupe 19,000 miles
2014 EV Cabriolet 13,500 miles
SFmike is offline  
post #7 of 8 (permalink) Old 09-12-2019, 07:44 AM
Moderator
 
sokoloff's Avatar
 
Join Date: Aug 2013
Location: Ocean Isle Beach, NC
Posts: 1,191
Thanks: 80
Thanked 160 Times in 124 Posts
Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 347 Post(s)
Garage
Thanks Mike. Keep us in the loop and keep us updated. You never know - someone here might stumble onto something that could help you and vise versa. As Mercedes disappears from the picture for us, more and more of us are going to need to become more aware of what's happening with our cars.

Good luck.

Len
2014 EV Coupe 19,000 miles
2014 EV Cabriolet 13,500 miles
sokoloff is offline  
post #8 of 8 (permalink) Old 09-12-2019, 07:49 AM Thread Starter
 
Join Date: Jul 2019
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Len

Np I will update as I get info in and if or when I get the faults from the HV battery repaired.

Quote:
Originally Posted by sokoloff View Post
Thanks Mike. Keep us in the loop and keep us updated. You never know - someone here might stumble onto something that could help you and vise versa. As Mercedes disappears from the picture for us, more and more of us are going to need to become more aware of what's happening with our cars.

Good luck.

Len
2014 EV Coupe 19,000 miles
2014 EV Cabriolet 13,500 miles
SFmike is offline  
The Following User Says Thank You to SFmike For This Useful Post:
MineCooky (Today)
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Smart Car Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.