Turbo Blown?!? - Smart Car Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-24-2019, 12:02 PM Thread Starter
 
Join Date: Jul 2017
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Turbo Blown?!?

Hi there I have a 2016 Auto with 75,000km on the clock, owned it since new almost 3 years in August.

CEL came on and lost lots of power. Towed it to the dealer and they said it needs a new turbo, under warranty thank god. Anyone else have a similar experience on a 3 year old car?
Farzooq Sayed is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Smart Car Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.