P0915 Code (Gear Shift Position Circuit Range/Performance) (Shifter motor) - Smart Car Forums
User Tag List

 1Likes
  • 1 Post By albertlastsmart
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 05-21-2019, 04:54 PM Thread Starter
 
Join Date: May 2019
Posts: 3
Thanks: 0
Thanked 2 Times in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
P0915 Code (Gear Shift Position Circuit Range/Performance) (Shifter motor)

Hello everyone... new to the forum in search of answers.



I have 2008 with 66,000 miles on it with the following issues:

- 3 Bars flashing

- after doing a reset, I can see the gears shift
- if I get it in D just for a bit the triangle light keeps flashing and eventually goes back to the three bars.

- P0915 Code (Gear Shift Position Circuit Range/Performance) once I ran my OBD connection

Top Reported Fix - Replace clutch actuator Motor M18 w/P0914,P1800



If i play around with the shifter, I can get the car started and on the display I can see P, N, R, D, and 1 once i move the gears. R is some what hard to get into to show on the display.


I've taken apart the clutch actuator and seems to be nothing broken in it but not sure. I've been reading up on this and it's look like a common issue with the actuator but looking on what is the best way to confirm it. Any help would be appreciative.

I took the actuator cover off and can see it functioning. Will see how I can upload a video of it.



Following verified:

- battery fully charged

- brake light switch is engaged.



Thanks in advance for the help!
Pardesi is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 05-21-2019, 10:13 PM
Super Moderator
SCOA Club
 
jimvw57's Avatar
 
Join Date: Sep 2008
Location: southern Minnesota
Posts: 11,182
Thanks: 306
Thanked 1,969 Times in 1,350 Posts
Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 806 Post(s)
Garage
There was a software upgrade back then for the transmission that you may not have gotten. Unfortunately the dealer is the only place to get it and they will most likely charge for it since it has been so long ago.
jimvw57 is offline  
The Following User Says Thank You to jimvw57 For This Useful Post:
strelnik (07-26-2019)
post #3 of 9 (permalink) Old 05-22-2019, 07:48 AM
 
Join Date: Feb 2017
Posts: 93
Thanks: 0
Thanked 13 Times in 10 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 20 Post(s)
Call before upgrade.............

If you call the smartcenter/stealership,and give your car's VIN number,they SHOULD be able to tell if your car
has had the latest software upgrades.....................
Smart Bob likes this.
albertlastsmart is offline  
The Following User Says Thank You to albertlastsmart For This Useful Post:
strelnik (07-25-2019)
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 05-22-2019, 08:51 PM Thread Starter
 
Join Date: May 2019
Posts: 3
Thanks: 0
Thanked 2 Times in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks, will give them a call and see what has been done.
Pardesi is offline  
post #5 of 9 (permalink) Old 07-25-2019, 07:53 AM
 
Jo e Lefors's Avatar
 
Join Date: Dec 2016
Location: 09 Cabrio Southern NV
Posts: 807
Thanks: 202
Thanked 89 Times in 81 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 204 Post(s)
Garage
Quote:
Originally Posted by Pardesi View Post
Hello everyone... new to the forum in search of answers.



I have 2008 with 66,000 miles on it with the following issues:

- 3 Bars flashing

- after doing a reset, I can see the gears shift
- if I get it in D just for a bit the triangle light keeps flashing and eventually goes back to the three bars.

- P0915 Code (Gear Shift Position Circuit Range/Performance) once I ran my OBD connection

Top Reported Fix - Replace clutch actuator Motor M18 w/P0914,P1800



If i play around with the shifter, I can get the car started and on the display I can see P, N, R, D, and 1 once i move the gears. R is some what hard to get into to show on the display.


I've taken apart the clutch actuator and seems to be nothing broken in it but not sure. I've been reading up on this and it's look like a common issue with the actuator but looking on what is the best way to confirm it. Any help would be appreciative.

I took the actuator cover off and can see it functioning. Will see how I can upload a video of it.



Following verified:

- battery fully charged

- brake light switch is engaged.



Thanks in advance for the help!
Any Updates on your clutch problems ? Seems we have another person with similar problems.
https://www.smartcarofamerica.com/fo...roblem-154758/
Jo e Lefors is offline  
post #6 of 9 (permalink) Old 07-25-2019, 08:12 AM
 
smark's Avatar
 
Join Date: Aug 2008
Location: Lenexa Ks.
Posts: 6,817
Thanks: 477
Thanked 1,235 Times in 880 Posts
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 668 Post(s)
There were two transmission updates, for the 2008 models. The first one address, a smoother shift. The second one, is how the paddle shifter performed, in the sport mode. I had both of those performed on my car. I doubt that isn’t your issue.
smark is offline  
post #7 of 9 (permalink) Old 07-25-2019, 08:18 AM
 
Jo e Lefors's Avatar
 
Join Date: Dec 2016
Location: 09 Cabrio Southern NV
Posts: 807
Thanks: 202
Thanked 89 Times in 81 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 204 Post(s)
Garage
Quote:
Originally Posted by Pardesi View Post
Hello everyone... new to the forum in search of answers.



I have 2008 with 66,000 miles on it with the following issues:

- 3 Bars flashing

- after doing a reset, I can see the gears shift
- if I get it in D just for a bit the triangle light keeps flashing and eventually goes back to the three bars.

- P0915 Code (Gear Shift Position Circuit Range/Performance) once I ran my OBD connection

Top Reported Fix - Replace clutch actuator Motor M18 w/P0914,P1800



If i play around with the shifter, I can get the car started and on the display I can see P, N, R, D, and 1 once i move the gears. R is some what hard to get into to show on the display.


I've taken apart the clutch actuator and seems to be nothing broken in it but not sure. I've been reading up on this and it's look like a common issue with the actuator but looking on what is the best way to confirm it. Any help would be appreciative.

I took the actuator cover off and can see it functioning. Will see how I can upload a video of it.



Following verified:

- battery fully charged

- brake light switch is engaged.



Thanks in advance for the help!
Quote:
Originally Posted by Jo e Lefors View Post
Any Updates on your clutch problems ? Seems we have another person with similar problems.
https://www.smartcarofamerica.com/fo...roblem-154758/
PARDESI..Any updates on your clutch problem ?
Jo e Lefors is offline  
post #8 of 9 (permalink) Old 07-26-2019, 05:57 AM Thread Starter
 
Join Date: May 2019
Posts: 3
Thanks: 0
Thanked 2 Times in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Quote:
Originally Posted by Jo e Lefors View Post
Quote:
Originally Posted by Pardesi View Post
Hello everyone... new to the forum in search of answers.



I have 2008 with 66,000 miles on it with the following issues:

- 3 Bars flashing

- after doing a reset, I can see the gears shift
- if I get it in D just for a bit the triangle light keeps flashing and eventually goes back to the three bars.

- P0915 Code (Gear Shift Position Circuit Range/Performance) once I ran my OBD connection

Top Reported Fix - Replace clutch actuator Motor M18 w/P0914,P1800



If i play around with the shifter, I can get the car started and on the display I can see P, N, R, D, and 1 once i move the gears. R is some what hard to get into to show on the display.


I've taken apart the clutch actuator and seems to be nothing broken in it but not sure. I've been reading up on this and it's look like a common issue with the actuator but looking on what is the best way to confirm it. Any help would be appreciative.

I took the actuator cover off and can see it functioning. Will see how I can upload a video of it.



Following verified:

- battery fully charged

- brake light switch is engaged.



Thanks in advance for the help!
Quote:
Originally Posted by Jo e Lefors View Post
Any Updates on your clutch problems ? Seems we have another person with similar problems.
https://www.smartcarofamerica.com/fo...roblem-154758/
PARDESI..Any updates on your clutch problem ?

Hi, I just got the issue resolved few weeks ago. It was the transmission shifter motor located up on top.

I was able to reset/re program it Everytime by playing with the ignition key and it would run fine. When u stop and restart the car, it would show the three bars. I would then re program and clear my codes and get going. So I thought it was more of a computer update. It ended up being the transmission shifter motor and some upgrade that was done.

Hope this help and thanks for reaching out.
Pardesi is offline  
The Following 2 Users Say Thank You to Pardesi For This Useful Post:
jwight (07-26-2019), Smart Bob (07-26-2019)
post #9 of 9 (permalink) Old 07-26-2019, 12:11 PM
I'll figger this car out
SCOA Club
 
Join Date: Jun 2019
Location: Detroit-Ann Arbor-Flint area
Posts: 93
Thanks: 90
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 20 Post(s)
Quote:
Originally Posted by jimvw57 View Post
There was a software upgrade back then for the transmission that you may not have gotten. Unfortunately the dealer is the only place to get it and they will most likely charge for it since it has been so long ago.


I just checked with the tech at Mercedes Benz-smart of Ann Arbor MI. This upgrade was automatically added to the 2009 model year. According to them there is no further upgrade. I asked if my 2009 Passion needed it, they said no such issue for anything after 2008.


So I guess the rest of us are ok.
strelnik is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Smart Car Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
P0805 Clutch Position Sensor Circuit problem chieftmc smart Operation and Maintenance 78 11-12-2018 05:13 PM
P0018 Crankshaft Position/Camshaft Position Correlation Bank 2 Sensor A(incl part #s) mrgreat smart Operation and Maintenance 14 07-24-2011 08:47 PM
obdii code P0887 TCM Power Relay Control Circuit High pitstopautoinc smart Operation and Maintenance 6 09-04-2009 02:37 PM
Say good-bye to Circuit City JPaul Tech & Gadgets 15 11-14-2008 12:18 PM
Circuit City includes smart jwight Tech & Gadgets 23 07-21-2008 05:19 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.