Transmission Teach-in not complete !! - Page 2 - Smart Car Forums
User Tag List

 3Likes
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 13 (permalink) Old 09-24-2017, 06:15 AM
 
slomarsh's Avatar
 
Join Date: Sep 2017
Location: SoCal
Posts: 40
Thanks: 1
Thanked 3 Times in 2 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Quote:
Originally Posted by Rouelf View Post
Huronlad, Tried implement your suggestion, but without the battery connected the transmission can only be placed on ’N” or “D”. Drove around the block with check engine light on, with the P0949 fault code. Everything seem to function / shift properly.

So, I guess to the Mercedes Benz dealer I may go (the local Smart Center). You are probably right about blaming the battery disconnect. Hopefully it is a warranty coverage. Otherwise there are horror stories about what may appear a seemingly simple issue that one can live with turn into $$$ fixes.

Thanks, for the time / suggestion !!
RE: P0949 code check engine light
Hello fellow Smart owners.
Had the same engine light/ P0949 code fault problem as stated above. I just installed a Roadmaster towing base plate to tow the "giggle box" behind our RV. All went very well towing it over 1000 miles.
However, same engine light problem occurred after towing and restoring the battery cut off switch using the exact procedure in the owner's manual. In all cases after driving some distance with the engine light on, the next re-start would clear the "check engine" light. Yesterday however, it took three restarts but the car was only driven a very short distance (a few feet) between the first two restarts. It may be the learning cycle is also mileage sensitive. After the third re-start I drove about 5 miles.

Jim M
SoCal
new member
slomarsh is offline  
Sponsored Links
Advertisement
 
post #12 of 13 (permalink) Old 09-24-2017, 10:05 PM
 
ManchVegas's Avatar
 
Join Date: Apr 2011
Location: Aberdeen, WA
Posts: 787
Thanks: 24
Thanked 204 Times in 143 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 26 Post(s)
Garage
For my 2009 Passion, below is my "After towing" procedure. The red text is my modification to the owners manual instruction.

Quote:
> After towing: Engage the parking brake.
> Turn the battery back on using the key for the previously installed battery disconnect switch.
>Move the gear selector lever to park position P.
> Turn the ignition key to the ON position. Listen for the transmission to cycle through the gears. P should appear on the multifunction display. If it doesn’t appear or you see the 3 bars of death, then move gear selector lever to the neutral position N, and listen again. When finished, N should appear on the multifunction display. Move the gear selector lever to park position P.
> If multifunction display shows P, start the car and set clock. If ESP warning light is on, turn the car off, wait 5 seconds and start it again. When done, turn the car off.
> Remove the ignition key from the starter switch.
> Lock the doors.
When I get a "Check Engine" light. I shut off the car, take the key out of the battery disconnect switch, count to 10, reconnect the battery, and restart the car.
ManchVegas is offline  
The Following User Says Thank You to ManchVegas For This Useful Post:
slomarsh (09-25-2017)
post #13 of 13 (permalink) Old 09-25-2017, 06:38 AM
 
slomarsh's Avatar
 
Join Date: Sep 2017
Location: SoCal
Posts: 40
Thanks: 1
Thanked 3 Times in 2 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks for your input. Next time I will try your check engine light suggestion turning off the battery switch again. Have had no other problems with "relearning" other than the check engine light. Though, I do leave the shifter in N while it relearns. After P appears, I shift into P.
slomarsh is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Smart Car Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission Freezeup - "Teach-In" heads-up Gar Blume smart General Discussion 6 10-13-2016 12:05 PM
Problem creating a tan code for fob teach in cfreidma Original (450) smart fortwo 3 06-30-2014 08:38 PM
Hand-held Scan Tool - Smart Clutch "teach"? George3 smart Operation and Maintenance 0 06-16-2014 02:09 PM
Limp Mode - need link to teach in smartyone smart General Discussion 6 10-16-2013 07:00 PM
Three "Teach-ins" in one month KennEMurray smart General Discussion 4 05-01-2013 06:30 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.