Smart Car of America Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I've owned my 2013 Electric Drive for 18 months (had 20k miles, now 35k). Great car overall, but air conditioning is weak compared to my daughter's 2012 Pure. Before I invest $$ to have A/C worked on, do other Electrics have tepid A/C? Thanks in advance.
 

·
Super Moderator
Joined
·
1,837 Posts
I rarely turn my AC on, but when I do, it cools nicely after giving it a few minutes to "warm" up. I usually put it on recirc.

Len
2014 EV Coupe 18,000 miles
2014 EV Cabriolet 12,500 miles
 

·
Registered
Joined
·
105 Posts
There seems to be a common leak near compressor in ac fitting. I saw mine was fixed before i had it and avyoutuber had same issue. Similar low miles. They also all seem to have wire scuff issue

Sent from my SM-N960U using Tapatalk
 

·
Premium Member
Joined
·
672 Posts
Poor air conditioning?

I have a 2014 ED and the air conditioning wouldn't blow cold air. I took it to Mercedes and was quoted $500-$600. A couple days later they said they were going to have to re-drain the system to fix a couple of O-rings and it will cost approx. $700. When I went to pick it up the total they wanted was approx $1,300. One year latter the air is not working again, considering other electric car options available on the market. I will never own another Mercedes Benz product in the future, and have to deal with the stealers for service.
 

·
Registered
Joined
·
1,320 Posts
My A/C on my 2015 451 ED failed two times in the first three years (fortunately on warranty).

The first time was a bad condenser temperature sensor (which seems to frequently fail on all Smarts) which was complicated by a broken connector to it. The temperature sensor diagnosis and replacement is an easy DIY job - look it up at Evilution.co.uk.

The second time they first replaced the compressor but the service techs did not seem to even know how to check its functioning (the weather was cool but a working compressor on the ED makes a very distinctive noise) and when I got home I found it still was not working. They then found that a signal wire to the compressor was worn through due to wire harness being cut by a sharp edge of the frame and repaired it. A post of where this wire harness wear or cutting occurs is here:

https://www.smartcarofamerica.com/forums/f170/brake-wiring-harness-chafing-151488/index3.html

If there are any future A/C failures I will try to fix myself or do without it. I rarely use the A/C anyway and I don't live in a climate where the battery pack chilling function is needed.
 

·
Registered
Joined
·
105 Posts
AC fix, I saw mine had AC repair before I had it, and saw others online with issues. Would also not excuse wire chaff issue as a cause

Sent from my 9024W using Tapatalk
 

·
Registered
Joined
·
8 Posts
99+ today in LA, my 2014 Smart ED cools down in about a mile, gets chilly in two. I follow protocol and "crack windows" to let the hot air out when starting drive and always try to park in the shade. I watch my display and find it interesting how projected mileage decreases by about 20% when a/c is on then recovers when a/c is turned off. Most of my drives are 10 miles or less.
 
1 - 7 of 7 Posts
Top