Smart Car of America Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
The radio works as radio only. I can set stations, but that is all. Pressing the SETUP button does nothing, no menu. Can't reset time. We bought the car this way with 12,300 miles on it. :shrug: Ideas? I pulled the radio fuse (#26) to "reboot" and replaced it. No change.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #3
It's under warranty, let the dealer sort it out....:)
I called Mercedes Customer Care and got a vague answer. "Take it to a dealer and have (it assessed). It may or may not be covered." I'm looking for someone here that may have had the same experience, knowledge. I don't trust the local dealer.
 

·
Super Moderator
MY08 cabrio MY09 cabrio Brabus MY15 ED
Joined
·
7,910 Posts
The radio works as radio only. I can set stations, but that is all. Pressing the SETUP button does nothing, no menu. Can't reset time.
Recent purchase from a previously owned independent dealer, ask them to look at it. "Cold calling" M-B Customer Care will be your "weakest link."

Sorry that you don't trust the local dealer (a common problem with ALL marquees). As jwight suggests, it should be under warranty - take it to a smart Center for repair and if they don't respond to your expectation level call M-B CS and ask that they "open a case."

Just in case, here is the link to MY17 smart Audio System . . .

https://www.smartusa.com/resources/...7/smart_audio_system_instructional_manual.pdf
 
1 - 4 of 4 Posts
Top