Smart Car of America Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
351 Posts
Discussion Starter #1
I have had my 453 passion in the shop twice and noted that the radio will not properly display the name of the song being played when using media. The answer form the tech is that the media is not formatted correctly. The memory stick that I am currently using is the same memory stick with the same data that worked properly in my 2013 pure, that works fine in my 2014 Kia Sportage, that works fine in my desk top computer. It is an issue in the firmware of the 453 radio.

Has anyone else notice this problem? Is smart USA aware of the problem and will the fix be coming with the fix for the Bluetooth problem?

Another question for smart USA: Can smart/Mercedes not build a speedometer that displays accurate speed.

Note to haters: I love my 453 passion and I loved my 2008 passion and I loved my 2013 pure.
 

·
Registered
Joined
·
7,197 Posts
Sounds like a 453 smart software issue. Though your USB. Not a Bluetooth issue. Have you tried a media player? A newer memory stick.
 

·
Registered
Joined
·
430 Posts
This might just be a quirk with the system. There is many things that seem short-sighted or absent from the upgraded smart-media navigation system I have.

Here's an example: In order to see the track artist and name from a radio station, you need to go into a menu to pop-up another window that will show you the name. you then have to MANUALLY close that window or none of the other buttons will work. Rediculous.

TRACK AND ARTIST NAME SHOULD BE SHOWN IN THE ROOT SCREEN OF THE RADIO WINDOW! I SHOULDN'T HAVE TO GO INTO ANOTHER MENU TO SEE THAT INFORMATION!

or how about this

IF I WAS CONNECTED TO BLUETOOTH AUDIO WHEN I TURN THE CAR OFF, RECONNECT AND PLAY BLUETOOTH AUDIO WHEN I START THE CAR THE NEXT TIME! (My 2014 toyota rav4 does this, and it has a cheapo audio system!)
 

·
Registered
Joined
·
351 Posts
Discussion Starter #4
Sounds like a 453 smart software issue. Though your USB. Not a Bluetooth issue. Have you tried a media player? A newer memory stick.
Yes I believe it is a firmware issue. Unfortunately too often at the dealer they dismiss issues with the car instead of following through with smart/Mercedes to get them resolved until it blows up in their face, for example Toyota, General Motors, and etc.
 

·
Registered
Joined
·
7,197 Posts
Do you own a smart phone with, music on it. You can play though Blue tooth. Does the 453 still have a AUX slot. Has the dealership, tried to reload software on your car. USB is the best input. Do you own a media device you can try.
 

·
Registered
Joined
·
2,550 Posts
Another question for smart USA: Can smart/Mercedes not build a speedometer that displays accurate speed.
If the speedometer is slightly optimistic but within the allowable 10% it is working correctly, as discussed in so many other threads.
 

·
Registered
Joined
·
351 Posts
Discussion Starter #9
If the speedometer is slightly optimistic but within the allowable 10% it is working correctly, as discussed in so many other threads.
In what world using modern electronics would an error of 10% be acceptable. If Daimler cant design and build instrumentation that is dead-nuts on they need to go into a different business.
 

·
Registered
Joined
·
1,571 Posts
My 1990 Benz sedan, the 1999 Jeep and the 2004 RX8 are spot on at 70 according to GPS. Both smart 451/453 coupes off by the same few mph as observed by many here.
 

·
Registered
Joined
·
1,199 Posts
Another question for smart USA: Can smart/Mercedes not build a speedometer that displays accurate speed.
I'm assuming yours is like mine, where the analog speedometer shows i'm going say 55mph, but the digital says i'm going say 54 or 56 (i've actually turned my digital speedo off, was annoying to have two speedometers, on top of the 3 clocks... so i don't recall if mine usually was over or under 1 MPH or so)? It's an acceptable margin of error.
 
1 - 12 of 12 Posts
Top