Smart Car of America Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1,235 Posts
I actually have one that i just purchased almost a month ago... and i have to say.... I almost wish i didn't. Sound quality seems VASTLY improved with it over the factory radio (more than 2 options in the equalizer probably helps loads with that). Plus it's nice being able to connect a nice high capacity SSD or something to it via USB and have all your music with you instead of a narrowed down selection of it.

Unfortunately, in my experience, that's about where the pluses end.

1) If you DO have a vast amount of music on a hard disk of some sort... be ready for a headache trying to find what you want to listen to. Their music player doesn't seem to just show you the folder tree as you would HOPE it would. Instead, it's some kind of jumble of it. For example, if i'm trying to scroll down to listen to an album i have saved from Sam Smith, I end up going past two other groups of artists/albums that start with "S" before i get to it. And can't seem to use ANY OTHER media player app, because none that i have yet to try are able to even see the attached hard drive, except Root Explorer, but that's hardly useful as a MUSIC player. For video, it works decently enough.

2) Same can be said about the phonebook. Nothing that ends up getting connected to these things seems to be in any sort of alphabetical order.

3) I tried using the phone mirroring app that's on the radio... downloaded the companion app on my phone that it said to download.... upon launching the app, it says it's only compatible with a certain manufacturer's or carrier's SIM card.... so that's useless as of now. Have yet to be bothered to try to find a different way of doing so.

4) They'll tell you over and over again that it's compatible with the 8-speaker JBL sound system... but it's not. At least... not the way it's shipped to you. Their wire harness works for everything, and every wire on the factory harness has a wire going to it.... except one. Unfortunately, that one wire is the remote wire that turns on the factory amp. No connection... no sound. I've tried explaining that to them, but seeing as English is nowhere near their native language, It's nigh on impossible to do so. Ever since i've had the radio, I've been using a twist tie that i've stripped the plastic off of to jump the connection between the required wire and the wire that would need to be connected to it on their harness. I've been wanting to PERMANENTLY connect it... but can't find anywhere that has a pin of the required size that i could attach and snap into place in their harness to attach to the required wire on the factory harness.

5) Google Maps is incredibly slow. Even when my phone is tethered to it so it has an internet connection, it doesn't want to load anything. I've already been on a drive back from a town i'd never been to before, with Maps loaded up and attempting to navigate me home... but it never downloaded the required maps, and for MILES it kept telling me what road i was on and where i was to turn... even after i had made several turns already.

I could probably think of more.... but I dunno. Maybe someone else has had a better experience with these things than I have.
 

·
Registered
Joined
·
1,235 Posts
So far the bluetooth seems fine with pairing to my Nexus 6P. But speaking of that... and after having just gotten back from a drive, i remembered something else.

6) Can't, for the life of me, get the head unit to pair with my bluetooth OBDII reader. Only way i've found to access bluetooth settings on the unit is by going into the phone app, and from there, it won't even let me attempt to put in the 4 digit key to pair with the reader.

7) Quite often I'll start the car, and when it finally starts playing music from the hard drive, I'll notice that I can no longer browse the music that's on the hard drive. Whatever songs were in the folder of the last song you had playing will still show up in the Playlist and can still be played, but if you tap the selection at the top part of the screen to browse the USB media, absolutely nothing shows up.

@Mister_smart_LA pretty sure he's not referring to bluetooth audio being poor, but the fact that the factory radio never seems to want to remain paired to the phone for more than a week most times.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top