Smart Car of America Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Hello...

Purchased 2013 smart for two a couple of days ago. It has 29k miles.

A couple of issues.

It wont start sometimes. The key wont engage the starter motor at all. After a few tries or when it is cold it fires. I am getting a crank sensor code. I ordered the beck arnley suggested here. It will arrive within a week. I have only drove it twice. Once it starts it does not die or anything.

The airbag light is on. From some reading here I need to have the dealer fix this?

Any chance it is under warranty?

Thanks
 

·
Super Moderator
Joined
·
29,027 Posts
Warranty is four years/50K miles - check the original owner purchase date or call your smart center and give them the VIN to know for sure.

And welcome to SCoA! :)
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
That is good so maybe the airbag could be resolved. It says 4/12 on the door as date of manufacture. I will call dealership in Nashville tomorrow. I am in Memphis.

Is a smart dealer the only one that would fix it under warranty?

Would crank sensor be covered as well?
 

·
Super Moderator
MY08 cabrio MY09 cabrio Brabus MY15 ED
Joined
·
7,784 Posts
Hello...

Purchased 2013 smart for two a couple of days ago. It has 29k miles.

A couple of issues.

It wont start sometimes. The key wont engage the starter motor at all. After a few tries or when it is cold it fires. I am getting a crank sensor code. I ordered the beck arnley suggested here. It will arrive within a week. I have only drove it twice. Once it starts it does not die or anything.

The airbag light is on. From some reading here I need to have the dealer fix this?

Any chance it is under warranty?

Thanks
Welcome to SCoA.

Does this car have a clean CarFax and Title?

Unless you stole it, this many problems after only two day says GO BACK all over it!

If it has a branded title, warranty may no longer be in place - good luck?
 

·
Registered
Joined
·
24 Posts
Discussion Starter #5
Car has a good title. One owner. Had these problems when i bought it. Very clean good looking car red/silver.

4750 and my tax plus license plate was 350 at the tag office.
 

·
Registered
Joined
·
333 Posts
Sounds like you got a good deal, as long as you are willing to work out the defects.
Mercedes distributes the Smart's in the US, and also do the warranty work, take it there.
I have had the airbag light intermittently, and need to get that looked at.
Mine is an all silver passion, 1015 with 25K. They take some getting used to as far as the
semi automatic transmission. I compare it to riding a motorcycle, but not having to
actually shift the gear, or activate the clutch!
Good luck, drive smart!
Remember, there is a warning in the passenger side rear view mirror.....
CAUTION, OBJECTS IN MIRROR "ARE" BIGGER THAN YOU.
 

Attachments

·
Super Moderator
Joined
·
1,606 Posts
Mercedes distributes the Smart's in the US, and also do the warranty work, take it there.
Are you sure this is accurate? My local Mercedes dealer told me they don't do any Smart service. Maybe it's different with warranty work? I always thought that the car had to go to a Smart dealership/service center.

Len
2014 EV
 

·
Registered
Joined
·
24 Posts
Discussion Starter #9
I called two mercedes dealers in Memphis and neither worked on Smart.

I am in Missouri with the car and will be driving to St. Louis tomorrow. It is a Mercedes/Smart dealer. They even reserved a 2016 for me as a loaner.
 

·
Registered
Joined
·
883 Posts
Give the car an extensive going over, if you find anything else have the dealership take care of those issues too since you have a narrow remainder window on the warranty.
 

·
Super Moderator
Joined
·
29,027 Posts
Are you sure this is accurate? My local Mercedes dealer told me they don't do any Smart service. Maybe it's different with warranty work? I always thought that the car had to go to a Smart dealership/service center.

Len
2014 EV
Not every Mercedes dealer carries the smart brand, but every smart center is a Mercedes dealer. :)
 

·
Registered
Joined
·
24 Posts
Discussion Starter #13
I dropped the car off, dealer ordered the crank sensor.

Dealer ordered the wrong sensor so they ordered another one.

They can't check the airbag problem until the sensor is fixed. I dunno why.

I was given a very nice mercedes as a loaner so no complaints here.

I was told since i dropped the car off before the warranty expired i would be ok if they had to keep it a while.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #14
Got the car back all is good.

I actually prefer the smart over the mercedes i had all week.

I do miss the cruise control and amazing sound system though.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #15
So my car was dying sometimes. Finally it died and would not start. I was on a hill with no traffic so I rolled back into a parking lot.

It would not start up so i plugged in my scanner and got a crank sensor code. I unplugged the sensor and plugged it back in then it fired up.

Careful inspection revealed the problem. One of the holes inside the plug was packed full of blue/green corrosion.

I got a can of electrical cleaner and a safety pin. I cleaned it out, and it has been doing great.

Perhaps the problem all along.
 

·
Premium Member
Joined
·
11,309 Posts
sounds like water is getting in there and causing the corrosion. I would pick up some dielectric grease (same as what they use on light bulb sockets) and fill the connector before plugging it in. Should keep the corrosion from returning
 

·
Registered
Joined
·
24 Posts
Discussion Starter #17
Still having trouble with this. Lightly touching the connector causes the engine to miss and stumble.

I found a local auto electric shop today. I am going to have them bypass the connector and solder directly to the crank sensor.

I could fix it but would rather have it done professionally as it is such a key part of the car.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #18
So... the crank sensor is fixed.

Car still dying and wont start sometimes.

No engine light no codes.

Only thing i see is a very corroded ground wire that is connected to the engine. Could that cause problems?
 
1 - 20 of 22 Posts
Top