Smart Car of America Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
11,891 Posts
I'm thinking the problems you are haveing have nothing to do with Millage. Sounds like your car was put together right after folks came back from vacation.

Get all your service records in order, compair to your CA Laws and be ready to present them to your dealer.
 

·
Registered
Joined
·
1,315 Posts
I have about 7200 miles on mine (Picked it up in January 09) and the only thing was the transmission put it self into limp mode, and after SmartUSA talked to Smart of Germany it was deemed as a fluke and if it happens again than its something wrong with the transmission, this happened at around 2500 or so... and nothing has happened since.

I've so far had no other issues, and love driving the car everyday.
 

·
Banned
Joined
·
5,087 Posts
Only about 5500 on my '09 and so far the only thing I've experienced was a pesky TPMS light that stayed on. I fixed it myself by checking the air pressures and resetting the button on the dash. Who woulda thunk:confused: :D
 

·
Registered
Joined
·
60 Posts
I'm at 12,500 miles on my '09 and the only issue I have had was a check engine light. It turned out to be a charcoal canister shutoff valve (Something like that) It was fixed quickly and I was on my way.
 

·
Registered
Joined
·
5 Posts
27000 miles on an 08 Cabrio here.. and was VERY close to considering it a lemon too. 3 crossover valve replacements, a bad steering wheel position sensor, and the dealer said they'd performed the shifter recall when they hadn't, stranding us one (of course) rainy night when the shifter locked up.. but it's been okay for the last 10k miles or so. Well, except for EATING tires and rims.
 
1 - 13 of 13 Posts
Top