Smart Car of America Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
After about 30 minutes driving, car smells like overheating then slips into neutral. I have to open engine compartment and sit for about 10 minutes before able to continue. No codes or any dash lights. Not sure what to do!
 

·
Super Moderator
Joined
·
29,352 Posts
Welcome to SCoA! :)

My WAG is it's either the clutch or the clutch actuator. Need to have the car scanned for OBD codes and then go from there.
 

·
Super Moderator
Joined
·
29,352 Posts
Was the scan done with a professional grade scanner that could read Mercedes specific fault codes? Most generic OBD scanners can't do that.

This sound like a clutch related issue and those will generally cause codes to set. How many miles on the car? :)
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
I would assume so a mechanic scanned it. There are about 170,000. It also has a new engine last year!
 

·
Super Moderator
Joined
·
29,352 Posts
Unless the clutch was replaced somewhere in all those miles I think it has finally worn out. :)
 

·
Registered
Joined
·
333 Posts
If you suspect overheating it may be useful to monitor the engine temperature. Either an device like the ScanGauge or UltraGauge or an ODB to Bluetooth adapter with an app like Torque on your phone.

~toaster
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
Have found that their is a small leak in the cooling system. Could this be the cause of the transmission going into Neutral?
 
1 - 10 of 10 Posts
Top