Smart Car of America Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey guys, very first post. Ive read some other posts about this but cant seem to find a solution for my situation.

Here's the issue my blinker went rapid awhile ago and then one day i noticed the bulb finally went out because when I locked my car the light didnt blink anymore.

I got a new bulb yesterday from Walmart and put it in.. At first it didn't work at all :crying: after trying to clean up some goop left behind from the old bulb (wiping it, blowing in the socket holder Nintendo style) the bulb light came on for the breaks but still didn't come on for the flasher/blinker for turning or hazard. I tested the bulb on the right side and it blinks and works just fine... So anybody have any ideas, from what ive read it could be a relay issue? But i cant seem to find a relay online that fits the 2008 fortwo.

Any help is appreciated, really dont want to pay money for a shop to figure it out. I'll attach pics below to help
 

Attachments

·
Registered
Joined
·
1,471 Posts
I would perform a few simple tests like checking to make sure your have power going to the bulb socket for the turn signal. A fellow smart owner had a similar situation and he replaced the entire bulb socket assembly & that corrected the concern.
 

·
Registered
Joined
·
883 Posts
You may want to clean the contacts - pencil eraser works. And fluff up the contacts for a more secure contact with the bulb base. Check for looseness in the connectors on the wire harness.

Sent from Tapatalk on Android
 
1 - 3 of 3 Posts
Top