Smart Car of America Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
Hi all first thanks for the input on my faded roof. I don’t drive my 08 Smart much 27,000mi but after a 10-15 mile drive and after turning off the Ignition I get oil smell, no signs of leak and oil changed a month ago it does dissipate fairly quick, is this normal ??
 

·
Registered
Joined
·
39 Posts
if you got a drip of oil while filling it, anywhere near the fill area there, itll get hot enough to smell burning. Last time I changed oil I did that, definitely not gonna get the 5qt jug next time! Took a couple weeks of daily driving for the last traces of smell to totally go away, but it was reasonable enough after a couple days.

course that doesnt help much if theres some other problem besides a lil dab of oil misplaced...
 

·
Registered
Joined
·
333 Posts
Take a look at the engine, top and bottom. If no leaks noted, then after some time the smell should stop. If not, there may be a leak... oil filter, gasket, spill etc.....
 

·
Registered
Joined
·
24 Posts
Check under the car and the top of the engine as dhlairbusb4 noted. I had a little tiny bit of oil that was dripping and getting burnt off before it hit the ground. At one point there was some faint smoke coming out of the bumper vents so I freaked out. I removed the panels and rear bumper and carefully pressure washed where all the oil was pooling to see where it could have came from.
Turned out to be a very loose valve cover bolt. I had 3 total that were pretty loose. I tightened them up and have not seen oil since then! I'm sure I'll have to replace the valve cover gasket one of these days but for now, no more oil or oil smell
 
1 - 4 of 4 Posts
Top