Smart Car of America Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
88 Posts
Discussion Starter #1 (Edited)
I've got a 2010 Passion coupe, this just started today. I drove to work and back, and everything seemed to be fine; the car is fully warmed up (30 mile round trip). I went to the grocery store, drove home from there and everything was still fine. I realized I forgot the main thing I went for, so I went back out and started back to the store. After about a block, I slowed down for a speed hump and the engine died. The shifter wouldn't go into p! but the engine restarted readily in N. At the end of the next block I slowed down again, and it died again. This time it would go into P, and restarted fine. The next block it died again at the stop sign. Again, shift into P, engine starts fine, but i was spooked and decided I'd go home and switch cars. I went arund the block and everything was acting fine, so I decided to try again - and the very next time I slowed down, it died again. I repeated the shift to P, restart and started to do a U turn when it died again. Another restart, and I made it home; when I pulled up behind my wife's car, it died again. I didn't try starting it again. If it helps, it's 18-20 degrees F out there, and I don't have a garage, so that's the temperature it's going to be at until maybe Friday. I just filled up Saturday at the same station I generally use, with 93 occtane premium. I haven't taken it anywhere to see if there are any codes yet. Any ideas?
Thanks.
Bob
 

·
Registered
Joined
·
8,987 Posts
...just to say I tried something I would do the "key on, hold the foot brake, run through all the gear positions including the manual mode (shifter to the left then right) and back up to park" kind of slowly to re set/teach the tranny since you said that it will not go into P...

Jetfuel...next....
 

·
Registered
Joined
·
88 Posts
Discussion Starter #4
Thanks for the suggestion, jet fuel, but it was only the first time that it wouldn't go into P. Every other time it shifted normally. And as soon as I get the chance, jwight, I'll be putting a dry gas treatment in - that was my hope for the problem, I'd love for us to b right!
Thanks,
Bob
 

·
Registered
Joined
·
88 Posts
Discussion Starter #6
I've added about 1/2 of a bottle of Heet, waited about 20 minutes and tried driving around my neighborhood. So far, so good! I guess it's time to switch stations - although I think the Kroger Fuel Center is about the highest volume station around, and I thought they were reselling Shell gasoline. Maybe it's time to try BP.
Thanks again,
Bob
 

·
Registered
Joined
·
11,472 Posts
Run a half can of Seafoam through it on the next tank. IF that doesn't do it, go to Walmart's boat section and get a bottle of StarTron :)
 
1 - 8 of 8 Posts
Top