Smart Car of America Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
2018 Electric smart4two.

The clock for the multi-function dashboard display is not keeping up with actual time. I reset it and it keeps correct time while the car is running. But after the car is shut down for a while (while at work, or overnight), when I return, the time is significantly behind the current actual time. The clock on the radio works just fine.

This happens almost every time I leave the car, whether it is plugged in to a charger or not. However, on rare occasions when I return to the car, the time on the clock will still be correct. Only maybe 4 or 5 times in the 2 months that I have had the car.

Anybody else have a similar experience? If so, any suggestions for solution?

This is a significant disappointment with winter coming as the schedule for the climate control pre-heating runs off this clock.
 

·
Registered
Joined
·
1,059 Posts
Very odd. I'd expect any kind of electronic clock to work correctly or not at all... Time to take it to a dealer for some warranty work, unfortunately.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
I did end up taking in to the dealership. At first they said it needed a software update, but that didn't work and they replaced the instrument cluster. Thankfully, covered by warranty.

Now it works fine.
 

·
Registered
Joined
·
624 Posts
Good to know

we have the same issue; clock seems to have a mind of its own -- will be sure to have them check it out at its annual check up in July and see if a new head unit is in order -- more just annoying that a real issue as I really only use it to determine when it will be fully charged so I can disconnect the charging cable. The rest of the car has been great and with a break in our spring weather is showing 90+ miles of range again
 

·
Registered
Joined
·
1,399 Posts
The clock on the tach/cluster in my 2016 ICE loses time. Not dramatically, but will be off a minute or few over the course of a few weeks after setting. Not so with the radio clock.
 

·
Registered
Joined
·
7 Posts
Clock not displaying

Clock shows "--/--" on the screen.

The menu item for "Time Setting" has been grayed out; i.e. unavailable.

Has been like this for 2 months.

Taking it into the dealership to have it checked out.

All other functions are seemingly normal.
 
1 - 7 of 7 Posts
Top