Smart Car of America Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey Everyone,

New to the forums. I tried searing for my problem but none of the threads I found seem to fit my issue exactly. Recently that air pump that turns on for 30 seconds when you start your car has had an awful grinding noise (sounds a little like the baby t-rex with the broken leg from jurassic park). Something is broken but I'm not sure what it is. Searching this forum I see that it might be the pump it's self and the valve that opens to allow air through. There are no check engine lights on the dash. Can anyone identify which part needs replacing based on the sound? Video below:

 

·
Premium Member
Joined
·
269 Posts
The bearings in the air pump go bad, My 08 started making that noise at about 58k mi. I had already purchased a used pump here on the forum. I would try to find a recycler and get one from a low mi '15
smart. Of course there is always the dealer. I still have my old unit and I took it apart but I don't think it is rebuildble. Mine never threw any codes due to this. I guess as long as it is making noise it is working!:D It is not too hard to replace. video on youtube if I remember correctly.
 

·
Registered
Joined
·
56 Posts
Justin, I have had to replace it - the secondary air injection pump - once at about 4 years old and mine is now out again at 8 1/2. MB is very pricy - have been looking around for alternatives but none so far. Don't think I want to trust an old used one. Like Hihosilver says - find one from a '15. I too took an old one apart and don't see anyway to repair. Jetfuel says he disconnected his, and light came on and he reset a couple of times before it stopped coming on. They aren't hard to replace, behind R/R fender liner, sitting on the frame rail. Wish I had a better answer, but haven't come up with a cheaper than $150 fix.
 
1 - 5 of 5 Posts
Top