Smart Car of America Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1,471 Posts
Hesitation/miss, harsh shift, etc:

I just experienced a similar situation when I drove my wife's 09 Pure with 12,550 miles today. The gear changes were harsh, and it would seem to hesitate which was either the engine missing or the clutch disengaging. This happened all of a sudden, as the car shifted perfectly before and we even drove it on a 175 mile trip a few days ago. The other thing that happened is when I refueled the car, the gauge didn't read all the way full. l fill the tank on slow auto setting and stop after it clicks off.
To remedy this issue, I backed the car up on ramps, checked the connectors underneath as well as the front motor mount. Nothing amiss. Next, I removed the engine cover and checked the hoses and connections and again, nothing amiss. Finally, I disconnected the battery for 30 minutes, reconnected it, rebooted the transmission, which read OK once I reconnected the battery, and took it out for a drive. It shifts like it should and the fuel gauge is now reading properly. Go figure?
 

·
Registered
Joined
·
1,471 Posts
Transmission Re-Learn Procedure:

When I reconnected the battery, my transmission was showing Park, & when shifted, it would display the gears. The re-learn procedure is simple. With the trans. selector in park, step on the brake pedal, turn the key to position 1, move the selector slowly through the gears and back to park. If the transmission is re-learning, you will hear some clicks coming from the back of the car. After returning to the park position, turn off the key, and then you can re-start the engine. Hopefully, everything will be functioning properly.
 
1 - 2 of 2 Posts
Top