Smart Car of America Forum banner

1 - 20 of 35 Posts

·
Super Moderator
Joined
·
28,699 Posts
Discussion Starter #1 (Edited)
Maybe you haven't noticed (neither did I until someone pointed it out) that smart has made a running change to the inside cover of the glass hatch - for 2010 models. They've added a drain hole at the bottom of the plastic cover, in the area where the lower end of the support struts are attached. Now, at least if your hatch does get some water in it the water has a place to drain out. Easy DIY for 2008 and 09 models - take a drill (1/8 inch bit or so) and put the holes in yourself. When you're done it should look like this:

 

·
Registered
Joined
·
89 Posts
yea my dealer [email protected]#$%d me off! they had their workers drill holes in mine and they didnt run a stop on the drill so they ofcorse went to deep and scratched my frit line on the back window so now when you look at it you see these horrable scratch marks from the drill scraping the frit line off.


:mad::mad::mad::mad::mad:
 

·
Registered
Joined
·
1,160 Posts
Water has recently been leaking into my hatch top. I'm having it repaired soon and will mention the drain hole as a fix.
 

·
Registered
Joined
·
186 Posts
one day the left side of my trunk has some wt droplets and the carpet is a little wet after heavy over night rain. is this related to this problem?
 

·
Registered
Joined
·
2,653 Posts
I'm bad, Holes in my what?:eek: Now I have to look. Haven't noticed any water sloshing around in the back and I don't know if there are holes in the hatch either.
 

·
Registered
Joined
·
81 Posts
I took mine (1/09) into the dealer while still under warranty (water was sloshing in the hatch) and they just drilled holes.
What was not good is all the RUSTY water that leaked out of the hole and left marks on the body. Came off but I'm curious.
Not sure it the water going thru the hatch will cause rust damage eventually.
 

·
Premium Member
Joined
·
1,274 Posts
Just drilled the holes, a surprising amount of clear water shot out from the hole on the driver's side, none on the other side. Thanks JWight for starting the thread and helping me to avoid future issues!
 
1 - 20 of 35 Posts
Top