Smart Car of America Forum banner

1 - 20 of 311 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1 (Edited)
Resetting maintenance indicator

I'm at 11K miles now and I've done all the required servicing but I can't reset that pesky maintenance indicator reminder that pops up when you turn on the ignition. I tried following the instructions on the owner's manual but I only end up resetting the odometer each time. I found the thread about it but still no luck.
 

·
Registered
Joined
·
2 Posts
I've just finished DIY change oil at 10,023 miles. However, I have the same problem in resetting the "wrench" maintenance indicator that blinks for about 10 seconds and then goes off. Can someone help me with a procedure how to clear this "wrench" symbol blinking everytime I start the engine?
 

·
Registered
Joined
·
262 Posts
I don't know about anyone else, but the dash buttons on my car need to be pressed rather firmly to obtain a response. When I first got it I thought they didn't work at all. Pressing harder did it.
 

·
Registered
Joined
·
274 Posts
I tried both methods for around and hour and just gave up. I then gave the instructions to someone else to see if I was missing something and they couldn't do it either. The only thing that happens is my mileage gets reset and the blinking wrench blinks for the ten seconds I'm holding the button then does nothing.
 

·
Registered
Joined
·
590 Posts
I don't know about anyone else, but the dash buttons on my car need to be pressed rather firmly to obtain a response. When I first got it I thought they didn't work at all. Pressing harder did it.
That was the situation with mine as well, in fact to get it to work the buttons had to be pressed so hard that it was painful. After doing this several times the pressure required was less for some reason.
I believe this may also be the reason why some others are having trouble getting the buttons to respond.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #10
I gave up after numerous tries and went to the Las Vegas Smart Dealership where it only took 5 minutes. The tech said that they had to hook it up to the computer to reset.
 

·
Lifetime Member
Joined
·
11,307 Posts
Apparently, (like the fog light update), some smarts have a bug in the code meaning they can't be reset using the button press method and they now have a bit of software to do it.
That sounds like the problem that I have, thanks for mentioning that as I was thinking I was getting a little slow in the head. :eek: I'm waayyyy past my reset time.
 

·
Registered
Joined
·
267 Posts
I had a terrible time re-setting my clock. Those of us Hoosiers are somewhat new to this whole idea of "Fall Back" anyway, and then I couldn't even take care of the clock issue. I did finally get it done, but what a pain!
 

·
Ex Admin/mod.
Joined
·
9,491 Posts
I had a terrible time re-setting my clock. Those of us Hoosiers are somewhat new to this whole idea of "Fall Back" anyway, and then I couldn't even take care of the clock issue. I did finally get it done, but what a pain!
At first, I tried doing it while I was in a hurry. Meaning, while driving. Bad idea! I had to stop and go around twice until I got the time right.
Good news: going forward next Spring will be really easier! :p
 

·
Registered
Joined
·
81 Posts
Now that I've reached 10,000 fun and trouble free miles, I have the problem of getting rid of the cute little service wrench. Over the past two days I've tried the two methods listed by evilution with no luck. Has anyone got a better idea or had problems resetting. My dealer is about 125 miles away.
 

·
Registered
Joined
·
525 Posts
Just wanted to kick out this tip:

if it doesn't work the first time, wait a full minute with the key off before trying again.

(it might not take a full minute, but if you wait you will be succesfull with the correct timing on the button pushing and key turning. it is quicker than you think.)
 

·
Registered
Joined
·
10 Posts
resetting maintenace indicator

If your maintenance indicator does not reset using the regular procedure. you need to take your vehicle to your smart dealer so it can be reset using the scan tool. If the maintenance indicator is on and your vehicle has less than 10000 miles, the instrument cluster has to be reprogrammed. It is an easy procedure, and only takes about 5 minutes.
 

·
Registered
Joined
·
202 Posts
Thanks EVILUTION!!!!

I just reset my "spanner". Used Evilution's NEW Encyclopaedia link and instructions:

Method 1

  • Switch on the ignition to position 1.
  • Select maintenance indicator within 4 sec by double tapping the instrument cluster button.
  • Switch of the ignition to position 0 (off) within 10 sec.
  • Push and hold in the instrument cluster button and switch ignition on.
  • Hold the instrument cluster button for another 10sec.
  • In that time, the spanner symbol on the LCD will flash and eventually reset.
 

·
Registered
Joined
·
1,422 Posts
Did my 10K service myself and it took me few tries, but I did reset the service light with help of Evilution Guide.


Thank you.


CUBE
 
1 - 20 of 311 Posts
Top