Smart Car of America Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi all.

Traded off our 2013 Smart Passion for a 2017 passion.

We got the 6 speed tranny with most of the other goodies.

TOP LINE SOUND SYSTEM WITH WOOFER.

The car made it about 25 miles before the warning center told us the brake booster had failed :eek:

Three weeks later the ses light came on and back to the shop.

Emissions system issues (Canister purge valve kaput)


Last week the imobilizer module died and NO START

All fixed now (I HOPE)

Far too many issues so soon me thinks.

Benz is chewing on it and will advise what they are going to do.

Missed a once in a lifetime vacation with family and a wedding during the trip.

Arrrrrrgh

Car quit when it was too late to do much except fume.

Car seems fine now.


fun fun fun
 

Attachments

·
Premium Member
Joined
·
2,297 Posts
Hi all.

Traded off our 2013 Smart Passion for a 2017 passion.

We got the 6 speed tranny with most of the other goodies.

TOP LINE SOUND SYSTEM WITH WOOFER.

The car made it about 25 miles before the warning center told us the brake booster had failed :eek:

Three weeks later the ses light came on and back to the shop.

Emissions system issues (Canister purge valve kaput)


Last week the imobilizer module died and NO START

All fixed now (I HOPE)

Far too many issues so soon me thinks.

Benz is chewing on it and will advise what they are going to do.

Missed a once in a lifetime vacation with family and a wedding during the trip.

Arrrrrrgh

Car quit when it was too late to do much except fume.

Car seems fine now.


fun fun fun
If the battery is weak on a 453, it will throw all kinds of codes. Most of them can be disregarded once you have a fully charged battery. I suspect this triggered your domino issues...
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Thanks for the reply

Actually, the brake booster unit was leaking vacuum and tripped the code.

The canister purge valve had failed and was stuck open.

The imobilizer module (theft detterent system part) failed and would not allow the car to start/run.

Battery was fine.

Mercedes fixed the issues, but is was just a pain to have this many troubles on a brand new rig
 

·
Registered
Joined
·
1,584 Posts
Thanks for the reply

Actually, the brake booster unit was leaking vacuum and tripped the code.

The canister purge valve had failed and was stuck open.

The imobilizer module (theft detterent system part) failed and would not allow the car to start/run.

Battery was fine.

Mercedes fixed the issues, but is was just a pain to have this many troubles on a brand new rig
Yeah, don’t blame you for not liking the list of issues with your new car! Other than the gas tank/gauge issue we haven’t heard much in the way of complaints on the 453s.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
Yeah.

It was not enjoyable having such a string of issues right out of the gate.

Still love the new little bug a lot.

The one issue that has not been addressed is the poor AC function.

In traffic on a HOT day running slow the air gets warm and then cool, but not COLD until we are rolling above 30 MPH for a bit, then is fine.

So in afternoon traffic ya sit and sweat ..../ WRONG

Told that this is perfectly normal.../ NOOOOOOOOOOOOOOOOOO.

I worked as an AC tech for years (Automotive and other) and warm/cool is not the way this is supposed to be.

The Merc shop handed me a service bulletin that explains that this anomaly is normal ?????????????


My 13 blew cold all the time it was on.


Not sure but it seems that if the S mode is selected the AC works better, but maybe this is just wishful thinking.

Warm air from the AC vents is not a stellar selling point.


Anyone else have this issue ????
 

·
Moderator
Joined
·
17,479 Posts
My 453 blows cold air all the time provided it's had a few minutes to get going. My 451 is the one that likes blowing warm air at a stop or moving slow.

As for issues, I feel your pain. My driver's door panel has a small tear in it, I noticed it when driving it home from California. The transmission also started acting weird too (never disengaging the clutch at a stop), but that was fixed with a software update.

When I asked the dealer to take a look at the door panel tear, not only did they not replace the fabric, but they oil soiled it, which is the condition it's been in ever since. My passenger door is visibly out of alignment too, yet the dealer won't fix because (and I quote) "we can't fix it unless there's a check engine light". Um guys, it's a DOOR PANEL!?!?

My next warranty visit will be over the clunky front suspension, which apparently there is a TSB about right now.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
Sounds like a feeble attempt at blowing you off.

Hmmmm, never heard of a crooked door panel setting a DTC ???????????


Some of these clowns amaze me at there antics.
 
1 - 8 of 8 Posts
Top