Smart Car of America Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello everyone... new to the forum in search of answers.



I have 2008 with 66,000 miles on it with the following issues:

- 3 Bars flashing

- after doing a reset, I can see the gears shift
- if I get it in D just for a bit the triangle light keeps flashing and eventually goes back to the three bars.

- P0915 Code (Gear Shift Position Circuit Range/Performance) once I ran my OBD connection

Top Reported Fix - Replace clutch actuator Motor M18 w/P0914,P1800



If i play around with the shifter, I can get the car started and on the display I can see P, N, R, D, and 1 once i move the gears. R is some what hard to get into to show on the display.


I've taken apart the clutch actuator and seems to be nothing broken in it but not sure. I've been reading up on this and it's look like a common issue with the actuator but looking on what is the best way to confirm it. Any help would be appreciative.

I took the actuator cover off and can see it functioning. Will see how I can upload a video of it.



Following verified:

- battery fully charged

- brake light switch is engaged.



Thanks in advance for the help!
 

·
Super Moderator
Joined
·
11,234 Posts
There was a software upgrade back then for the transmission that you may not have gotten. Unfortunately the dealer is the only place to get it and they will most likely charge for it since it has been so long ago.
 

·
Registered
Joined
·
808 Posts
Hello everyone... new to the forum in search of answers.



I have 2008 with 66,000 miles on it with the following issues:

- 3 Bars flashing

- after doing a reset, I can see the gears shift
- if I get it in D just for a bit the triangle light keeps flashing and eventually goes back to the three bars.

- P0915 Code (Gear Shift Position Circuit Range/Performance) once I ran my OBD connection

Top Reported Fix - Replace clutch actuator Motor M18 w/P0914,P1800



If i play around with the shifter, I can get the car started and on the display I can see P, N, R, D, and 1 once i move the gears. R is some what hard to get into to show on the display.


I've taken apart the clutch actuator and seems to be nothing broken in it but not sure. I've been reading up on this and it's look like a common issue with the actuator but looking on what is the best way to confirm it. Any help would be appreciative.

I took the actuator cover off and can see it functioning. Will see how I can upload a video of it.



Following verified:

- battery fully charged

- brake light switch is engaged.



Thanks in advance for the help!
Any Updates on your clutch problems ? Seems we have another person with similar problems.
https://www.smartcarofamerica.com/forums/f4/please-help-me-my-451-smart-problem-154758/
 

·
Registered
Joined
·
6,886 Posts
There were two transmission updates, for the 2008 models. The first one address, a smoother shift. The second one, is how the paddle shifter performed, in the sport mode. I had both of those performed on my car. I doubt that isn’t your issue.
 

·
Registered
Joined
·
808 Posts
Hello everyone... new to the forum in search of answers.



I have 2008 with 66,000 miles on it with the following issues:

- 3 Bars flashing

- after doing a reset, I can see the gears shift
- if I get it in D just for a bit the triangle light keeps flashing and eventually goes back to the three bars.

- P0915 Code (Gear Shift Position Circuit Range/Performance) once I ran my OBD connection

Top Reported Fix - Replace clutch actuator Motor M18 w/P0914,P1800



If i play around with the shifter, I can get the car started and on the display I can see P, N, R, D, and 1 once i move the gears. R is some what hard to get into to show on the display.


I've taken apart the clutch actuator and seems to be nothing broken in it but not sure. I've been reading up on this and it's look like a common issue with the actuator but looking on what is the best way to confirm it. Any help would be appreciative.

I took the actuator cover off and can see it functioning. Will see how I can upload a video of it.



Following verified:

- battery fully charged

- brake light switch is engaged.



Thanks in advance for the help!
Any Updates on your clutch problems ? Seems we have another person with similar problems.
https://www.smartcarofamerica.com/forums/f4/please-help-me-my-451-smart-problem-154758/
PARDESI..Any updates on your clutch problem ?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #8
Hello everyone... new to the forum in search of answers.



I have 2008 with 66,000 miles on it with the following issues:

- 3 Bars flashing

- after doing a reset, I can see the gears shift
- if I get it in D just for a bit the triangle light keeps flashing and eventually goes back to the three bars.

- P0915 Code (Gear Shift Position Circuit Range/Performance) once I ran my OBD connection

Top Reported Fix - Replace clutch actuator Motor M18 w/P0914,P1800



If i play around with the shifter, I can get the car started and on the display I can see P, N, R, D, and 1 once i move the gears. R is some what hard to get into to show on the display.


I've taken apart the clutch actuator and seems to be nothing broken in it but not sure. I've been reading up on this and it's look like a common issue with the actuator but looking on what is the best way to confirm it. Any help would be appreciative.

I took the actuator cover off and can see it functioning. Will see how I can upload a video of it.



Following verified:

- battery fully charged

- brake light switch is engaged.



Thanks in advance for the help!
Any Updates on your clutch problems ? Seems we have another person with similar problems.
https://www.smartcarofamerica.com/forums/f4/please-help-me-my-451-smart-problem-154758/
PARDESI..Any updates on your clutch problem ?

Hi, I just got the issue resolved few weeks ago. It was the transmission shifter motor located up on top.

I was able to reset/re program it Everytime by playing with the ignition key and it would run fine. When u stop and restart the car, it would show the three bars. I would then re program and clear my codes and get going. So I thought it was more of a computer update. It ended up being the transmission shifter motor and some upgrade that was done.

Hope this help and thanks for reaching out.
 

·
I'll figger this car out
Joined
·
222 Posts
There was a software upgrade back then for the transmission that you may not have gotten. Unfortunately the dealer is the only place to get it and they will most likely charge for it since it has been so long ago.


I just checked with the tech at Mercedes Benz-smart of Ann Arbor MI. This upgrade was automatically added to the 2009 model year. According to them there is no further upgrade. I asked if my 2009 Passion needed it, they said no such issue for anything after 2008.


So I guess the rest of us are ok.
 
1 - 9 of 9 Posts
Top