Smart Car of America Forum banner
21 - 31 of 31 Posts

Registered
Joined
14 Posts
67080


Up there is the photo of my retrofit set. I gathered up all the parts, then noticed there is no wiring harness in my Smart 451 2007. Gave up, wanted to sell it. Nobody wanted to buy it and I eventually decided to proceed with the mod.

Because I had no wires in my Smart 451 laid down for rain sensor, I bought following Mercedes rain sensor wiring harness (W203 Rain Sensor Wiring Harness Roof OEM 2035409006 D92):
67081


Here is the list of the items I needed:

The Signal Switcher (used) A451 545 0010 /004

The Rain Sensor (used) A451 900 12 01

The cover for the rain sensor (used) A 451 821 00 36

The wire cover for the rain sensor (bought in Mercedes Dealership, unpacked) A 451 820 00 69

The Rain Sensor Sticking Pad (new, unpacked) - from AliExpress


Dead Dash Pods
I disconnected the rain sensor. Dash Pods came back again including the rev counter. The wiring diagram from Evilotuion is not correct (they have it the other way around). At the beginning I was paying attention to the colours of wires (same colours should go together - well it does not work that way).

Rain sensor wiring:
Red yellow cable
(also the power cable) goes to N11-9 slot 14 --> this explains why the power is connected to Dash Pods. They come up only when you twist the stalk in "AUTO"position and therefore it activates rain sensor.

Violet blue cable (rain sensor's signal cable) goes to N11-2 slot 1 --> this should be LIN B! On Evilotion is the wiring the other way around. Anyway, this is the cable for additional instruments such as rain sensor.

Brown Earth cable (I guess it could go anywhere with other earth cables).

I spoke to my dealer and next week I we will try it to hook up on Star Diagnostics and activate it as mentioned above a.k.a. DRL funciton as we could not find a "rain sensor" in the diagnostics scheme on the first go.

Fingers crossed. 馃
 

Registered
Joined
14 Posts
Here is another thing I have noticed. The wiring diagram from Evilotion is correct on the end of the day. I dowloaded the wiring scheme of 451 from OEM Mechanical and Collision Information | ALLDATA and compared the data.

Here is corrected scheme:
Red yellow cable (also the power cable) goes to N11-2 slot 1 --> This is the "power line" for additional instruments incl. rain sensor.

Violet blue cable (rain sensor's signal cable) goes to N11-9 slot 14 --> this is the "signal line" and LIN B!

Brown Earth cable (I guess it could go anywhere with other earth cables).

Once you connect the rain sensor without the Star Diagnostic activation, it switches off your Dash Pods (lighting and Rev counter) - I guess because there is no signal. I disconnected the rain sensor and I will wire it next week just before the activation through diagnostics.

Should work fine. :)
67087
67088
 

Super Moderator
Joined
29,302 Posts
Doesn't sound right to lose the dash pods with the rain sensor activated...:)
 

Registered
Joined
557 Posts
Correct me if I鈥檓 wrong, but I think the right control stalk on the steering column needs to be updated as well.
 

Registered
Joined
14 Posts
We will see. My updates were delayed as my dealer bailed out on the very last minute. I found another one. Tomorrow, we are going to do it through DAS. I will keep you updated!
 

Registered
Joined
14 Posts
All right, guys! Here is the promised update! Apparently, you cannot code rain/light sensor for Smart Fortwo 451 in DAS STAR Diagnostics. It is not enough. You gotta get Vediamo and "factory set" the equipment in.

In Vediamo you need to code and activate (there is a list of equipment, therefore it is not hard, really):
Lichtsensor (done)
Regensensor (done)

also maybe:
Komfortlichts vorne (we did not activated those) - I think they might refer to "Comfort/light package (from German Komofort).
Komfortlichts hintern (we did not activated those).

After the activation, my stalk reacts differently (the headlights will switch off, when on "Auto"), but sadly it seems to not be getting any signal from the rain sensor.

To be honest, I might have **** my rain sensor up, when I war tying to wire it in SAM for the second time. But wouldn't it blew a fuse? Is there a way to test if a rain sensor is working outside of the car?

Weirdly enough, whenever I connect the rain sensor to "LIN B" and "Additional Equipment" cables in the SAM, my Dash Pods stop working. Only, when I switch the cables, my Dash pods will come back up again... (But this was probably the way how I blew my rain sensor).

I think my rain sensor is faulty, but not 100% sure about that. It still might me coding problem or an old SAM unit... Honestly, we were working on it for 2,5 hours and did not get to the core of the problem.

When I connect the rain sensor, DAS Diagnostics thinks there is an electrical problem. Only when rain sensor is disconnected, the problem on DAS disappears...

Another theory is:
1) My SMART 451 software needs an update (software is from March 2006) --> They can do it only in Original Mercedes Dealership.
2) My Smart 451 needs a newer SAM unit.
3) It still might be a coding problem.
4) Rain sensor is faulty.

On the end of the day we managed to activate DLR lights function. Which is quite handy and I'm really grateful for that

Any ideas / advices?
 

Registered
Joined
14 Posts
Another updated. This time I think I might have destroyed my car completely, because of rain sensot. 馃槶馃槶馃槶

I was still not getting satisfying results with the rain sensor. The dash pods died no matter what. I swapped the wires incl. earth wire. My car went crazy. It started spontaneously honking, my speedo won't come up etc.

I disconnected the battery. But it looks like some sort of circuit short...
 

Registered
Joined
14 Posts
All right. Problem solved. I just connected the car to the battery again, left it there for 20 min, then 3 lines on the speedo appeared, pressed brake pedal, started as usual.

But honestly, Idk how to activate the rain sensor... It is way harder than I thought it is going to be...
 

Registered
2017 453 ForTwo Coupe ED
Joined
87 Posts
Was the rain sensor originally available on the '07? I'm wondering if the '07s software doesn't know what to do with it?
 

Super Moderator
Joined
29,302 Posts
Was the rain sensor originally available on the '07? I'm wondering if the '07s software doesn't know what to do with it?
Apparently it was: Comfort/light package (electrically adjustable and heated door mirrors, rain/light sensor, driveway illumination) :)

 

Registered
Joined
14 Posts
Honestly, guys. I think that the feature should be there. It might be coding thing (Vediamo has 4 layers of coding), we could have forgot something鈥 But I do not have Vediamo myself and I cannot play around with it at home.

But there might be 1000 other reasons why the rain sensor is not working鈥

I鈥檓 really frustrated. It seems like I鈥檓 going to blow up my car before I will retrofit the rain sensor. The radiator fan won鈥檛 switch off now, unless I disconnect the battery. 馃槵馃槵馃槵 I left it on for 1,5 hours, it goes on an on... I guess it probably won鈥檛 鈥渇ix itself鈥 as before.

Yeah, it was stupid to conciously plug in the wires the other way around than they were supposed to be. Apperantly, do anything, but this鈥

I asked Mercedes Dealership in Prague, if they can update my SAM unit. They said no. Only if 鈥淢ercedes invites you鈥 you may get the update. Isn鈥檛 that nuts?
 
21 - 31 of 31 Posts
Top