Smart Car of America Forum banner

1 - 3 of 3 Posts

·
DabusdriverOp
Joined
·
4 Posts
Discussion Starter #1
Folks anyone who can help with this issue I'd greatly appreciate it:

Problem; Right Front Turn Signal does not work, neither does the right side marker (yellow light forward of door). Rear turn signal on right side works fine. Here is what I have done so far:

1) Replaced right turn signal bulb
2) swapped left and right turn signal bulbs (Left did not work in right but right worked in left)
3) took all bulbs from front and rear and swapped left to right and right to left, (Right turn signal still did not work, but all left side worked fine)
4) Took front clip off, took right headlight our and cleaned sockets/connectors with electrical contact cleaner, pried metal contact out so they would make better contact (turn signal still not working)
5) Plugged left haedlight into right connector and turn signal did not work (but it worked fine when connected to left connector)
6) Plugged right headlight into left connector and the turn signal worked

Scratching my head, anyone have any clues they can throw me? All other lights (headlight (both) and parking lights) work fine.
 

·
DabusdriverOp
Joined
·
4 Posts
Discussion Starter #3
Does it make sense for my situation that it could be the relay, when the left headlight and turn signal worked fine when I plugged it into the right headlight connector? Just seems wierd, but thank you for the input. I guess I'll have to go see the dealer in Buckhead, near Atlanta, 2 hour drive. Thanks again.
 
1 - 3 of 3 Posts
Top