Smart Car of America Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
Replaced engine 2008 passion replaced clutch actuator, engine starts and runs great for about 1 and 1/2 minutes then shuts off by itself, replaced the crank sensor because at first it would not start. After not starting for a week I let it sit and it started and now it’s doing the shutting off thing.???
 

·
Registered
Joined
·
435 Posts
Is it setting any codes?
If I were to guess, perhaps a fuel delivery issue?
Disagnostics will help though.
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #3 ·
It shows crank sensor which has been changed twice to make sure. For a week it would not start at all, then after being parked a week we went to push it inside for storage this winter I just tried and it fired right up. Now it starts every time then shuts off, by the way it won’t start again unless you wait a few hours.
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #4 ·
It shows crank sensor which has been changed twice to make sure. For a week it would not start at all, then after being parked a week we went to push it inside for storage this winter I just tried and it fired right up. Now it starts every time then shuts off, by the way it won’t start again unless you wait a few hours.
Any other answers guys or girls, running out of idears
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #6 ·
Looks like that’s where I’m going next, runs perfect for about 1-2 minutes , I was wondering if an emergency shut off could be triggering the shut down
 
1 - 6 of 6 Posts
Top