Smart Car of America Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello guys I am new to the thread and the car, I got the car in April, and decided to do some needed repair work and service. Did a oil change, front brakes,door speakers were blown,and left rear cv axle was damaged due to rear boot being torn. I did all the work and replaced the cv axle, and the car would never stay engaged with the gear, you can drive about 40 ft then it just stops gong and comes out of gear, prior to that , I would at times have issues with the selector having the D display but wouldnt engage then I would have to cycle the key then restart and all would be fine.. I am just confused as to why after cv axles replacement it wont stay in gear..I like the car but I am maybe thinking I made a mistake with my purchase. I cant find any shop that will touch it, and the nearest dealership is in Jax fl..I had a buddy who scanned it with star and codes are p1901 and p1902 shift operation 1 and 2.. any ideas ? any help would be greatly appreciated
 

·
King of Smart Gadgetry
Joined
·
1,051 Posts
A P1901 is Transmission Speed Sensor has circuit intermittent malfunction. P1902 is Pressure Control Solenoid B intermittent short (which doesn't make any sense to me). But it sounds as though the clutch actuator is engaging the clutch and then 40 feet later disengaging the clutch and the car will not move in either direction? Sounds like the transmission control module is not receiving a signal from one of the sensors that detects the vehicle is actually moving. I think I would crawl underneath and check all the wiring connectors. Perhaps you unknowingly damaged a wire or partially unplugged a connector. It happens to the best of us. If you find something then I would do a disconnect of the battery for a few minutes. Then I would try to do the Reteach procedure. You don't have to unhook the battery to do the reteach but I like to anyway. The reteach causes the computer to move your electric shift motors back to a predetermined position according to info from the sensors. Then the computer knows how far to run the shift motor that drives the shift rails in the transmission to change gears. It also resets the clutch actuator within the limits that it can so that everything is synchronized again and the car can start anew.

Here is the official unedited version of the reteach procedure with all the extra fluff included. DCO

From the 2011 manual:
Quote:
In case of a minor transmission
malfunction, it might be possible to teach-in
the transmission in order to restore the
normal transmission mode.

If the attempt to teach-in the
transmission fails, you cannot continue
to drive. Therefore we strongly
recommend that you have the
transmission taught-in at a qualified
workshop or at an authorized smart
center.

Teaching-in the transmission system:
X Stop the vehicle in a safe location.
X Move the gear selector lever to park
position P.
X Turn off the engine.
X Wait at least 30 seconds before
restarting.
X Press the brake pedal.
X Restart the engine
Three bars instead of P appear in the
multifunction display.
X Wait at least 30 seconds.
The transmission is taught in.
When teaching-in was successful: P
appears in the multifunction display again
and normal transmission operating is
restored.
X Continue to drive. (We hope).
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
hello and thanks very much, I really appreciate your reply,yes correct the car just pops out of gear, but I feel some light thumping under my feet just before it pops out of gear as if the clutch pedal assembly is failing.. I removed the bottom panel , inspected everything, the only thing that was installed under there was the left rear abs sensor which plugs into the pigtail.. its new..I also forgot to mention that we had a C1323 which us a CAN FAULT WITH THE SPRINT SHIFT MODULE.. I checked the tcm fuse 40amp and it was good.the only thing that was unplugged was the abs sensor plug,which we replaced...I am actually a BMW technician but no smartcar experience...Maybe the wiring loom is bad? Just cant understand why this would happen, I will double check all connections again..I have access to the Mercedes Star system...but I will keep you posted and check everything as you suggested... thanks again... if you ever need a Jaguar BMW,LANDROVER,or Mercedes question please ask, I have worked for them all...
 

·
Registered
Joined
·
1 Posts
Hi.
hello and thanks very much, I really appreciate your reply,yes correct the car just pops out of gear, but I feel some light thumping under my feet just before it pops out of gear as if the clutch pedal assembly is failing.. I removed the bottom panel , inspected everything, the only thing that was installed under there was the left rear abs sensor which plugs into the pigtail.. its new..I also forgot to mention that we had a C1323 which us a CAN FAULT WITH THE SPRINT SHIFT MODULE.. I checked the tcm fuse 40amp and it was good.the only thing that was unplugged was the abs sensor plug,which we replaced...I am actually a BMW technician but no smartcar experience...Maybe the wiring loom is bad? Just cant understand why this would happen, I will double check all connections again..I have access to the Mercedes Star system...but I will keep you posted and check everything as you suggested... thanks again... if you ever need a Jaguar BMW,LANDROVER,or Mercedes question please ask, I have worked for them all...
Hi.i am haveing exacly the same problem with my smart 451 diesel.my fault codes are P1903 and P1904 so i have issues with the 3th and the 4th gear with the same sympthomes like you have.
Would you please tell me if you could manage this on your smart already?
The car has visited 3 different workshops but none of them could fix it or even get closer to the solutions.all the wires has been checked all the plugs was checked and all of them suggested to change the gearbox but i feel is not right.
Thank you
 

·
10Year+ Supporting Member
Joined
·
3,435 Posts
@Makatak 912Guy has not been active since 9/23/18, the day after he joined the site. Since we never got the 451 cdi's in the states or Canada, you may want to try the UK site Evilution.com You will get lots of good info there. Good luck and welcome to SCoA.
 
1 - 5 of 5 Posts
Top