Smart Car of America Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
hi i pulled a bone head move and sprayed down seat and carpet with power sprayer
cleaned most water up with wet vac and got heater running to dry everything else.
think i got something wet when i turn key on get an error ! put in P or D . then square comes up blank when P,D,R should show
i got power every where else any ideas?
Thanks
 

·
Super Moderator
Joined
·
28,288 Posts
Welcome to SCoA!

You are right, bad idea putting water into the cabin - lots of electronics in there.
The transmission control module may have been soaked. Did you try removing the carpet and drying out individual components? Might try disconnecting the battery for 20 minutes or so and then reconnecting; also try the transmission relearn process from the owners manual. :)
 

·
Registered
Joined
·
2,783 Posts
Not sure if you know this because it seems to be your first post, but the battery is under the carpet, albeit higher up, on the passenger side. Oh boy, must have been really dirty!

Wait, heater? Did you accidentally kill your battery? What heater are we talking about????
 

·
Premium Member
Joined
·
2,297 Posts
Once everything dries up all should go back to normal. Do make sure to check for future corrosion and moisture underneath the carpeting, and also where various control units are located under the seats and behind the dash. Spend lots of time drying while everything is wet; don't wait for the mildew stench to kick in. It definitely will in a smart car, especially if you are in a warmer climate.
 
1 - 4 of 4 Posts
Top