Smart Car of America Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hey Guys,

Hope you all are doing well.

So I got my Smart about 2 months ago. When I first had it delivered I took for a spin and everything seemed fine, until I took it on the highway. The poor thing was really unstable bordering dangerous lol. So I took it to Mercedes and they found the problem. They said the sway bar was broken and they replaced it.

Whenever I got the car back from the dealership it was dream, the steering was super tight and it was very solid on the highway. However, I took a trip to CT for Christmas and noticed the steering is kinda loose again, not 100% stable anymore... not the way it was before, but I feel like it's getting worse by the minute. I'm sure if I take it back to Mercedes they will try and fix it again, since it's been merely a month since it was there for fixing.

My real question is, is this a common problem with these cars? I live in NYC and there pot holes galore here, so I wonder if hitting potholes might've cause the sway bar to break (again) or if it's a chronic problem of Smart Cars.

Thanks,
 

·
Super Moderator
Joined
·
29,385 Posts
Welcome to SCoA! :)

My guess is the potholes are causing your issues. The smart doesn't have a lot of suspension travel and most 451 owners avoid hitting potholes and manhole covers wherever possible. Any good auto repair shop can work on your car, including the computers if they have access to the Mercedes STAR system program. Parts are available from aftermarket sources like Rock Auto, NAPA, etc. - but they won't all carry everything you might need. Here's one source for the sway bar should that actually be the problem: https://www.autobahnsmart.com/suspension/fortwo-passion-pure-oem-frpnt-sway-bar-185mm
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Hi Jwight!! Thank you for the warm welcome.

I see, mine is a 2016 Prime, is that a 451? So yes I think it might be it, because it's giving me the exact same "symptoms" as before I took it to get fixed.

I'm just gonna bring it back to Mercedes since I'm sure the repair is still under warranty. But good to know I don't have to bring it to Mercedes every time something happens.

Thank you for your help.
Best Regards,
 

·
Super Moderator
Joined
·
1,854 Posts
If it's at all convenient, I'd definitely take it back to Mercedes. Their warranty on parts is one year, unlimited mileage. Now if they find something else wrong, that's coming out of your wallet.

I think 2016 ICE's are 453's. 2016 EV's are 451's.

Len
2014 EV Coupe 19,500 miles
2014 EV Cabriolet 16,500 miles
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
@sokoloff I'm definitely going to take it back there. It was fixed about a month ago, so I'm sure they'll redo the service. If it's something else it is still under warranty through Smart USA AND the dealership warranty so, no money coming out of my pocket. lol

Thank you for the info.
 

·
Super Moderator
Joined
·
29,385 Posts
Hi Jwight!! Thank you for the warm welcome.

I see, mine is a 2016 Prime, is that a 451? So yes I think it might be it, because it's giving me the exact same "symptoms" as before I took it to get fixed.

I'm just gonna bring it back to Mercedes since I'm sure the repair is still under warranty. But good to know I don't have to bring it to Mercedes every time something happens.

Thank you for your help.
Best Regards,
Yes, your car is a 453 so that sway bar link would not work for your car. :)
 
1 - 6 of 6 Posts
Top