Smart Car of America Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
My 2009 Brabus just had it's 40k service and now the tire pressure monitor light is on. Tried to reset it, as did Smart tech, but looks like one or all the sensors are bad. What a waste of time and money this will be. Anyone able to tell me the best way to replace these, where to buy them for a good price and if I need to go to Smart to have anything programmed after installing them? Prob expensive at Smart dealer. Or just put black tape over they warning LED. LOL!! :D

THANKS!

Franimal62
2009 Brabus
The worst MPG Smart I've owned!
32mpg on average.:eek:
 

·
Registered
Joined
·
738 Posts
Some tire stores can check the TPMS units without taking the wheels off. Once you have the offending bad TPMS identified, you can decide the next course of action. Good luck.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #3
Thanks! Local tire store couldn't check them. Go figure. I'll end up buying 4-and replacing them all at some point. I'm sure they're all original from 2009.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #5
I just took apart my speedo and covered the light. Problem solved.
My thoughts exactly. My laziness put a small piece of electrical tape over the light. Can't even tell it's there. I ck my tires for correct air and really don't need another electronic gadget to tell me if my tires are low! Covered that passenger air bag light soon after. Dumbest idiot light ever! LOL
 
1 - 5 of 5 Posts
Top