Smart Car of America Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
First thank you to everyone who answered the questions about the raw gas smell . It was the fuel pump . Thank God Russ is good at working on cars ! It was a 250.00 part and now that’s good ! Now back to the not wanting to go into reverse ???? If I take it to drive and back it seemed ok then russ took it to work and it did it and that didn’t work ? he had to turn on and off the ignition a few times ???? Anyone else have this and what did fix it ?
 

·
Registered
Joined
·
1,471 Posts
Take your car into a smart Center & check to make sure it has all the software updates regarding your concern. There are two updates, I believe, that address this issue.
 

·
Premium Member
Joined
·
11,310 Posts
Do a trans re-teach and see if that works. If you are able to shift into the manual mode by holding down the right shift lever, you most likely have the updated software. At this point in time, you will probably be charged for software updates.

I usually go into drive before going into reverse and have no problems
 

·
Registered
Joined
·
3 Posts
Ive learned to "slowly" shift into reverse from park, works fine when I do the slow shift. If I drop it into reverse from park quickly it misbehaves. Also, I have found that if I park on a slope/angle the issue is even worse, I have to put it into drive first and then reverse and it makes a rather nasty clunk noise with about a 30% chance of staying in reverse.
 

·
Registered
Joined
·
42 Posts
Last year I had the same problem in my 2009. Sometimes it wouldn't go into Reverse.
I took it to the dealer and had the software update done. They are aware of the issue.

Not one failure since then.
 

·
Super Moderator
Joined
·
17,623 Posts
My high mileage 2012 has recently started being a little weird getting into Reverse. Wiggling the gear knob a little seems to do the trick. Whatever locks it into the notch may be getting a little worn.
 
1 - 8 of 8 Posts
Top