Smart Car of America Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
729 Posts
Discussion Starter #1
I know it sounds like a stupid question, but here goes;

My EVSE cable broke and I believe this is covered under warranty. My question is:

Do I have to bring in the whole car or can I just bring in the cable? The trip to the dealership is a 1.5 charge trip (meaning about an 8 hr drive each way.)

The cable still functions, but every time I unplug my smart it leaves the “cup” portion in my smart. (If that makes any sense.)


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
2,947 Posts
I’m familiar with EVSE failure from the Ford side, only.

In that case better to call them first and ask. (Always helpful to be as polite and courteous as possible). Mixed reviews on getting it fixed under warranty over there. I have a feeling it’s the same here, having had issues with MB products before...
 

·
Registered
Joined
·
729 Posts
Discussion Starter #3
I’m familiar with EVSE failure from the Ford side, only.

In that case better to call them first and ask. (Always helpful to be as polite and courteous as possible). Mixed reviews on getting it fixed under warranty over there. I have a feeling it’s the same here, having had issues with MB products before...


Yeah. Well aware of that. I’ll be nice as pie. I’m going to be calling them in a few hours. I’m going to ask first if I have to bring the whole car or just the charge cable.


Sent from my iPad using Tapatalk
 
1 - 3 of 3 Posts
Top