Smart Car of America Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
Hello fellow smart friends,
I bought OEM Brabus LED's for my '13 smart. Brought the car to Mercedes to activate the lights but they couldn't figure out how to activate them. I was wondering if anyone can tell me how to hardware them to my Sam using R4 port.
Thank you,
 

·
Registered
Joined
·
2,964 Posts
The local dealer in my city does not currently sell smarts. It is under expansion, and rumor is it will. I don't think Fletcher Jones or their Ontario location does either.

Some that do sell them just don't seem to, (and in this particular case just the people on the service side), have been educated on the finer points of smart service, sadly.

No other alternative dealership to try?

www.smarttekinfo.com is quite pricey nowadays, but instructions on retrofitting, at least the hardware, should be there....
 

·
Registered
Joined
·
37 Posts
Discussion Starter #7
The local dealer in my city does not currently sell smarts. It is under expansion, and rumor is it will. I don't think Fletcher Jones or their Ontario location does either.

Some that do sell them just don't seem to, (and in this particular case just the people on the service side), have been educated on the finer points of smart service, sadly.

No other alternative dealership to try?

www.smarttekinfo.com is quite pricey nowadays, but instructions on retrofitting, at least the hardware, should be there....
Unfortunately I believe the next choice in dealerships is the Mercedes-Benz of Manhattan in NYC which is 3 hours away. That's why I'm looking to just hardwiring the LED's to the SAM instead of paying another $50 plus $30-40 in tolls to tell me they can't do anything
 
1 - 9 of 9 Posts
Top